Привод L. G. не работал в Windows 7

По ходу тестовой эксплуатации Windows 7 столкнулся с неожиданной проблемой — система упорно отказывалась работать с моим LG GH22NS30. Собственно, с проблемой я столкнулся ещё раньше — устанавливать новую ОСь пришлось с флешки, ибо привод на одном из этапов установки бесследно «исчезал».
Как оказалось, виной тому отсутствие в «семёрке» нормальной поддержки IDE-режима для SATA-устройств (а упомянутый привод, как и многие другие, выпущенные в годы оны, импользует именно этот режим).
Решается проблема довольно просто. Если вы только думаете установить Windows 7, то достаточно переключить в BIOS Setup редим работы привода с IDE на AHCI (обычно эта опция находится в разделе RAID options или что-то в этом духе — зависит от версии BIOS).
Если система у вас уже установлена, то предварительно (это важно, поскольку в противном случае система просто не загрузится!) внести небольшие изменения в реестр: в ветке HKEY_LOCAL_MACHINESystemCurrentControlSetServicesMsahci измените значение ключа Start на 0 (по умолчанию там обычно записано значение 3).
После перезагрузки Windows 7 заново установит драйвер привода — и всё заработает.

17 комментариев

  1. От Роман

    Ответить

  2. Ответить

  3. От Роман

    Ответить

  4. Ответить

  5. От Роман

    Ответить

  6. От Роман
  7. Ответить

  8. От Роман

    Ответить

  9. Ответить

  10. От Роман

    Ответить

  11. От dragulovmed1

    Ответить

  12. Ответить

  13. От boroda65

    Ответить

  14. Ответить

  15. От ВЛАДИМИР

    Ответить

  16. От Сергей

    Ответить

  17. От sergok

    Ответить

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *